Odpowiedz 
 
Ocena wątku:
  • 2 Głosów - 4.5 Średnio
  • 1
  • 2
  • 3
  • 4
  • 5
Trx Wolf
SP9XCC Offline
Krzysztof
**

Liczba postów: 84
Dołączył: 13-03-2019
Post: #161
RE: Trx Wolf
No i udało się zrobić stereo na forum Smile

Andrzeju,
Tobie właściwie chodziło o sprawdzenie czy Win 7, a właściwie czy Quartus, widzi Twoje FPGA...
Cóż, z treści powyżej wytnij wszystko co jest po zdaniu z "Hardware setup"... i jeśli masz widzianego USB Blastera naciśnij "Auto detect"...
Powinno zadziałać i powinieneś zobaczyć identyfikator Twojego układu.
Nie jest to jednak do końca pewne, szczególnie z tzw. chińskimi wersjami układów.
Normalnie jednak, podpina się układ i uruchamia tryb programowania.
Wtedy, jeżeli układ jest rozpoznawany, jest programowany i tyle.

Nie sztuką jest coś zrobić, sztuką jest zrobić tak, aby nie zepsuć..

Pozdrawiam,
73! Krzysztof
31-07-2022 21:43
Znajdź wszystkie posty użytkownika Odpowiedz cytując ten post
SP6AUO Offline
Andrzej
*****

Liczba postów: 974
Dołączył: 20-09-2009
Post: #162
RE: Trx Wolf
Donoszę,że mały postęp jest.
Blaster jest widoczny.
Programowanie failed.
İmage , İmage
Wszystkim Duże Dzięki.
Jutro jeszcze raz to pooglądam.
Już coś dopatrzyłem.Brak ptaszka w ISP

Andrzej
(Ten post był ostatnio modyfikowany: 31-07-2022 21:48 przez SP6AUO.)
31-07-2022 21:44
Znajdź wszystkie posty użytkownika Odpowiedz cytując ten post
SP9XCC Offline
Krzysztof
**

Liczba postów: 84
Dołączył: 13-03-2019
Post: #163
RE: Trx Wolf
Sprawdź dokładnie zasilanie Altery.
Napięcia muszą być zgodnie ze schematem.
Tam, wskutek lutowania na polach z małymi odstępami, mogą być zwarcia.
Jeżeli napięcia są OK, sprawdź poprawność sygnałów (ciągłość połączeń) od wtyku JTAG do układu.
Nie wiem czy wcześniej nie pisałem o tym...
-------------
Edit:
Następna rzecz to EEPROM.
Jaki masz wlutowany?
Powinien być 16 Mb - 25Q16.
Też się zdziwiłem, że w specyfikacji jest 8Mb - 25P80, a w firmware jest wyraźnie 16Mb.

Nie sztuką jest coś zrobić, sztuką jest zrobić tak, aby nie zepsuć..

Pozdrawiam,
73! Krzysztof
(Ten post był ostatnio modyfikowany: 31-07-2022 21:57 przez SP9XCC.)
31-07-2022 21:57
Znajdź wszystkie posty użytkownika Odpowiedz cytując ten post
SP6AUO Offline
Andrzej
*****

Liczba postów: 974
Dołączył: 20-09-2009
Post: #164
RE: Trx Wolf
Jeszcze raz się przyłożyłem.
Auto detect dał taki efekt

İmage
Niestety bez efektu.
Jeszcze raz dzięki.
Jutro też jest dzień.

Andrzej
31-07-2022 22:18
Znajdź wszystkie posty użytkownika Odpowiedz cytując ten post
SP9XCC Offline
Krzysztof
**

Liczba postów: 84
Dołączył: 13-03-2019
Post: #165
RE: Trx Wolf
To może tak naciśnij ten przycisk "Test JTAG chain" ?
Inaczej to się raczej niczego nie dowiemy...

Nie sztuką jest coś zrobić, sztuką jest zrobić tak, aby nie zepsuć..

Pozdrawiam,
73! Krzysztof
01-08-2022 16:58
Znajdź wszystkie posty użytkownika Odpowiedz cytując ten post
SP6AUO Offline
Andrzej
*****

Liczba postów: 974
Dołączył: 20-09-2009
Post: #166
RE: Trx Wolf
Cały dzień kopałem, sprawdzałem, ale jedno mi nie daje spokoju.
Która ver. wsadu jest pod mój zestaw ?
Czy może być ta 4.0.0
İmage

Andrzej
02-08-2022 21:39
Znajdź wszystkie posty użytkownika Odpowiedz cytując ten post
SP9XCC Offline
Krzysztof
**

Liczba postów: 84
Dołączył: 13-03-2019
Post: #167
RE: Trx Wolf
Powiem tak...
Ja zaczynałem od 3.51.
Później dałem 4.0 - z nią coś było nie tak... ja mam VCXO 20 MHz...
Zmieniłem na 4.1 i tak narazie jest.
Każdy wsad do FPGA powinien działać.
Przy wsadzie do procesora trzeba określić z jakim wyświetlaczem (bądź bez) ma działać.
Do procesora próbowałem dać 4.2 kiedy został wydany - niestety w moim przypadku zegar systemowy działał 100 razy szybciej... sekundy zasuwały jak w stoperze setne sekund...
Obecnie widzę, że jest wydany 4.3 do procesora... nie ma kiedy sprawdzić.

Nie sztuką jest coś zrobić, sztuką jest zrobić tak, aby nie zepsuć..

Pozdrawiam,
73! Krzysztof
02-08-2022 22:19
Znajdź wszystkie posty użytkownika Odpowiedz cytując ten post
SP6AUO Offline
Andrzej
*****

Liczba postów: 974
Dołączył: 20-09-2009
Post: #168
RE: Trx Wolf
Mam cały czas tak:
İmage
klikam automatyczne wykrycie i mam tak:
İmage
Nawet tu nie ma mojej altery.
Coś można inaczej ?

Andrzej
03-08-2022 9:04
Znajdź wszystkie posty użytkownika Odpowiedz cytując ten post
SP9XCC Offline
Krzysztof
**

Liczba postów: 84
Dołączył: 13-03-2019
Post: #169
RE: Trx Wolf
Nie naciskaj "Auto detect" tylko "Start".
Jeżeli dalej będzie "Failed" to masz conajmniej trzy opcje:
1. Masz malowankę Atltery...
2. Masz zwarcie lub zimny lut na końcówkach Altery
3. Masz nieprawidłowe sygnały na JTAG.
W przypadku pierwszym - tylko współczuć.
W przypadku drugim - sprawdzać wszystko pin po pinie zgodnie ze schematem.
W przypadku trzecim - jak wyżej.
Jeszcze jedna myśl - na płycie masz wlutowane gniazdo zgodnie ze schematem?
Czy jedziesz na gołych pinach?
Masz pewność, że pin 1 jest pinem 1?
Jeżeli tak i masz gniazdo - spróbuj zamienić końcami kabel - ten 10 żyłowy pomiędzy USB Blasterem a płytą.
Jeśli nie masz gniazda na płycie - upewnij się, że pin 1 jest pinem 1.
Jeżeli to nic nie daje, to jeszcze "mój" sposób - załącz zasilanie płyty i trzymaj cały czas wciśnięty (lub zewrzyj) przycisk zasilania i w tym stanie spróbuj.
U mnie tak zadziałało...
No i najważniejsze być może - sprawdź czy napięcia na zasilaniu Altery są prawidłowe... tam sobie można zrobić chyba w trzech miejscach zwarcia pomiędzy napięciami...

Nie sztuką jest coś zrobić, sztuką jest zrobić tak, aby nie zepsuć..

Pozdrawiam,
73! Krzysztof
(Ten post był ostatnio modyfikowany: 03-08-2022 9:52 przez SP9XCC.)
03-08-2022 9:52
Znajdź wszystkie posty użytkownika Odpowiedz cytując ten post
SP6AUO Offline
Andrzej
*****

Liczba postów: 974
Dołączył: 20-09-2009
Post: #170
RE: Trx Wolf
Wczoraj sprawdziłem wszystkie piny do masy.Jest ok
Na płycie mam gniazdo 10-cio pinowe.
Wszystkie napięcia na alterze są prawidłowe.
Dostałem przed chwilą taki komunikat:
Error (209015): Can't configure device. Expected JTAG ID code 0x020F30DD for device 1, but found JTAG ID code 0x020F10DD.
Może to coś wyjaśni.

Andrzej
03-08-2022 10:16
Znajdź wszystkie posty użytkownika Odpowiedz cytując ten post
Odpowiedz 


Skocz do:


Użytkownicy przeglądający ten wątek: SP7GRV, 2 gości